MySQL Forums
Forum List  »  Connector/C++

Installing a C++ connector on CentOS
Posted by: S v
Date: August 12, 2013 03:07PM

I'm trying to install a C++ MySQL connector on a centOS 6.4 64bit machine.
I've installed MySQL 5.6 ( a server and client component, and an additional shared component in order to get the mysqlclient.s0 libraries )
It seems to work fine.

On the site I've found the following file :
Red Hat/Oracle Enterprise Linux ver. 6 (x86, 64-bit), Compressed TAR Archive
After reading the INSTALL file I've tried to invoke cmake . , but got an error about a missing CMakeLists.txt.
Later I found out I need the actual source code in the drop down pane :
- Generic Linux (Architecture Independent), Compressed TAR Archive
there is a CMakeLists.txt file in the directory of the the source code
and I am able to run : cmake .

- why is there also the platform specific download ?
- Can I get by with only the source code ?

when I run cmake . from the directory, I get the following output:
CMake Warning (dev) in CMakeLists.txt:
A logical block opening on the line

/home/mysql-connector-c++-1.1.3-linux-el6-x86-64bit/source/CMakeLists.txt:39 (if)

closes on the line

/home/mysql-connector-c++-1.1.3-linux-el6-x86-64bit/source/CMakeLists.txt:41 (endif)

with mis-matching arguments.
This warning is for project developers. Use -Wno-dev to suppress it.

-- Environment compile flags:
-- Environment link flags:
CMake Error at CMakeLists.txt:120 (MESSAGE):
Boost or some of its libraries found. If not in standard place please set

-- Configuring incomplete, errors occurred!

this is the content of lines around line CMakeLists.txt:39-41 :
if(COMMAND cmake_policy AND POLICY CMP0015)
cmake_policy(SET CMP0015 NEW)
endif(COMMAND cmake_policy)

this is the content of lines around line CMakeLists.txt:120 :

# Try dynamic
MESSAGE(FATAL_ERROR "Boost or some of its libraries found. If not in standard place please set -DBOOST_ROOT:STRING=")

- I don't understand. did it find the boost components or it didn't ?
and if it did, why is this an error?
- I've installed/updated boost components with : yum install boost
this is the output of a : find / -name *boost* :


I've tried to run the cmake . with the following parameters without luck :

cmake . -DBOOST_ROOT:STRING=/usr/lib64/
cmake . -DBOOST_ROOT:STRING=/usr/share/doc/

Any help will be greatly appreciated!

Options: ReplyQuote

Written By
Installing a C++ connector on CentOS
S v
August 12, 2013 03:07PM
S v
August 19, 2013 02:35PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.