Re: Mysql server issues
Posted by: Jose Ramirez
Date: October 09, 2022 11:48AM

Hi,
Ah, seems like you already went through changing the installation location when initially installing MySQL Server. By default, the server is installed as a windows service with name MySQL80, did you keep this configuration or did you uncheck the "Configure MySQL Server as a Windows Service" checkbox during configuration?

If MySQL Server was installed as a service the MySQL80 Windows service is executed automatically and there is no need to manually run the "mysqld" command since the server will already be running. If you unchecked the mentioned checkbox a mysqld process was started instead (which needs to be manually started if you later restart your machine).

The error you mentioned in your original message is most likely being shown because either mysqld is already running or because you need to provide some parameters such as specifying the location of the my.ini file which contains the settings for the server. If no other mysqld process is currently running you should be able to start the server with the following steps:

1. Open cmd window as an admin.
2. Navigate to the folder where the mysqld.exe is located.
3. Run command: mysqld.exe --defaults-file="C:\ProgramData\MySQL\MySQL Server 8.0\my.ini" --console

Hope this helps.

====================================
Jose Ramirez
MySQL on Windows Team

Options: ReplyQuote


Subject
Views
Written By
Posted
587
September 22, 2022 07:06AM
242
September 22, 2022 09:23AM
199
September 24, 2022 07:18PM
Re: Mysql server issues
234
October 09, 2022 11:48AM
189
October 10, 2022 06:46AM
172
October 10, 2022 02:15PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.