MySQL Forums
Forum List  »  InnoDB

setting up innodb
Posted by: bob lambert
Date: March 28, 2005 07:15PM

Help

I am trying to use Innodb in mysql 4.1.9. I commented out the skip-innodb line in my.cnf, and set a few other things ...


#skip-innodb
# Uncomment the following if you are using InnoDB tables
innodb_data_home_dir = c:/apachefriends/xampp/mysql/
# set max limit to 100m
innodb_data_file_path = ibdata1:10M:autoextend:max:100M
#innodb_log_group_home_dir = c:/apachefriends/xampp/mysql/
#innodb_log_arch_dir = c:/apachefriends/xampp/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
set-variable = innodb_buffer_pool_size=16M
set-variable = innodb_additional_mem_pool_size=2M


I created innodb tables and loaded them using sql input. Things seemed to be going fine, but then I had a couple problems.

When I run phpmyadmin and look at my system variables it shows storage engine = myisam and table type = myisam. The reason I mention this is because I was having problems storing data to db (using ms access front end, tried to add new record to table (recordset actually), got error update linked table failed foreign key constraint, could not find logic issue w/ tables, and foreign keys existed) .... So I decided to export the DB and see what it looked like. Well the output established some of my tables as friggin myisam ! I loaded 'em all as innodb !

I have tried to change the system variables in my.cnf as follows:

#set-variable = storage_engine=innodb
#set-variable = table_type=innodb

they are commented out because they didn't work.

Not sure if that is even related to my problem or not, but I sure could use some help.

How do I set the storage engine and table type at server startup ?

Does it matter what the values are if my loaded tables are innodb ?

why doesn't output=input when I export ?


Thanks
Bob

Options: ReplyQuote


Subject
Views
Written By
Posted
setting up innodb
5218
March 28, 2005 07:15PM
2315
March 29, 2005 06:06PM
2202
May 20, 2005 01:11PM
2283
July 08, 2005 04:31AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.