MySQL Forums
Forum List  »  Performance

Re: large-pages variable set but mysql doesn't use huge pages
Posted by: Peter Moberg
Date: April 21, 2008 03:17PM

Hi Andres,

I have exactly the same problem. My system is running RHEL5.1, has 16GB ram and 8GB is reserved for large pages (4000 pages). Did you find out how to change the limit in RHEL?


mysqld.log:
080421 13:14:12 mysqld started
InnoDB: HugeTLB: Warning: Failed to allocate 8404992 bytes. errno 13
InnoDB HugeTLB: Warning: Using conventional memory pool
080421 13:14:12 InnoDB: Started; log sequence number 0 263654696
Warning: Failed to allocate 331350016 bytes from HugeTLB memory. errno 13
Warning: Using conventional memory pool
080421 13:14:12 [Note] /usr/libexec/mysqld: ready for connections.
Version: '5.0.22' socket: '/var/lib/mysql/mysql.sock' port: 3306 Source distribution

################

mysql> show variables like '%large%';
+---------------------+---------+
| Variable_name | Value |
+---------------------+---------+
| large_files_support | ON |
| large_page_size | 2097152 |
| large_pages | ON |
+---------------------+---------+

################
/proc/meminfo:
MemTotal: 16189364 kB
MemFree: 7010124 kB
Buffers: 176248 kB
Cached: 439488 kB
SwapCached: 0 kB
Active: 467720 kB
Inactive: 382232 kB
HighTotal: 0 kB
HighFree: 0 kB
LowTotal: 16189364 kB
LowFree: 7010124 kB
SwapTotal: 2031608 kB
SwapFree: 2031608 kB
Dirty: 224 kB
Writeback: 0 kB
AnonPages: 234212 kB
Mapped: 40692 kB
Slab: 92508 kB
PageTables: 21080 kB
NFS_Unstable: 0 kB
Bounce: 0 kB
CommitLimit: 6030288 kB
Committed_AS: 965760 kB
VmallocTotal: 34359738367 kB
VmallocUsed: 2104 kB
VmallocChunk: 34359735107 kB
HugePages_Total: 4000
HugePages_Free: 4000
HugePages_Rsvd: 0
Hugepagesize: 2048 kB


################
my.cnf:
[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
# Default to using old password format for compatibility with mysql 3.x
# clients (those using the mysqlclient10 compatibility package).
old_passwords=1

large_pages = true

skip-locking
key_buffer = 384M
max_allowed_packet = 1M
table_cache = 512
sort_buffer_size = 2M
read_buffer_size = 2M
read_rnd_buffer_size = 8M
myisam_sort_buffer_size = 64M
thread_cache_size = 8
query_cache_size = 32M
# Try number of CPU's*2 for thread_concurrency
thread_concurrency = 8
user=root

[mysql.server]
#user=mysql
user=root
basedir=/var/lib

[mysqld_safe]
log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid


# For performance
[isamchk]
key_buffer = 256M
sort_buffer_size = 256M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 256M
sort_buffer_size = 256M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout

Options: ReplyQuote




Sorry, you can't reply to this topic. It has been closed.
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.