MySQL Forums
Forum List  »  Replication

Re: Could not find first log file name in binary log index file
Posted by: Paul Eident
Date: January 14, 2009 08:41AM

This is an old post, but I'm having the same problem. The replication was setup with another developer of whom is not available.

The server is Linux RedHat. MySQL: 5.0.48-log

The replication is not working since the master crashed on Sunday night.

mysql> show slave status\G;
*************************** 1. row ***************************
Slave_IO_State:
Master_Host: XX.XX.XXX.XXX
Master_User: replicant
Master_Port: 3306
Connect_Retry: 60
Master_Log_File: mysqld-bin.000009
Read_Master_Log_Pos: 108959
Relay_Log_File: mysqld-relay-bin.000001
Relay_Log_Pos: 98
Relay_Master_Log_File: mysqld-bin.000009
Slave_IO_Running: No
Slave_SQL_Running: Yes
Replicate_Do_DB: krexdb,krexdb
Replicate_Ignore_DB:
Replicate_Do_Table:
Replicate_Ignore_Table:
Replicate_Wild_Do_Table:
Replicate_Wild_Ignore_Table:
Last_Errno: 0
Last_Error:
Skip_Counter: 0
Exec_Master_Log_Pos: 108959
Relay_Log_Space: 98
Until_Condition: None
Until_Log_File:
Until_Log_Pos: 0
Master_SSL_Allowed: No
Master_SSL_CA_File:
Master_SSL_CA_Path:
Master_SSL_Cert:
Master_SSL_Cipher:
Master_SSL_Key:
Seconds_Behind_Master: NULL

mysql> show master status\G
*************************** 1. row ***************************
File: mysqld-bin.000009
Position: 116642
Binlog_Do_DB:
Binlog_Ignore_DB:
1 row in set (0.00 sec)

Here is the error in the log.

090113 22:08:44 [Note] Slave SQL thread initialized, starting replication in log 'mysqld-bin.000009' at position 108959, relay log '/var/run/mysqld/mysqld-relay-bin.000001' position: 4
090113 22:08:44 [Note] Slave I/O thread: connected to master 'replicant@74.86.147.210:3306', replication started in log 'mysqld-bin.000009' at position 108959
090113 22:08:44 [ERROR] Error reading packet from server: Could not find first log file name in binary log index file ( server_errno=1236)
090113 22:08:44 [ERROR] Got fatal error 1236: 'Could not find first log file name in binary log index file' from master when reading data from binary log
090113 22:08:44 [Note] Slave I/O thread exiting, read up to log 'mysqld-bin.000009', position 108959

Any help to fix this problem would be appreciated. It's probably something simple.

Thanks in advance.

-paul

Options: ReplyQuote


Subject
Views
Written By
Posted
Re: Could not find first log file name in binary log index file
26216
January 14, 2009 08:41AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.