MySQL Forums
Forum List  »  Backup

Re: mysqldump -> Unknown suffix '/'
Posted by: Kelly Jones
Date: January 30, 2005 03:04AM

I also have mySQL 4.0.18 on Debian.

I was getting the exact same error message. I never tried running mysqldump, though. I was receiving the error upon trying ANYTHING at all with mysqladmin. I couldn't even get it to tell me "mysqladmin --version" without getting the "unknown suffix" thing

I tracked down every bash and/or perl script on my system that I could find, and opened them all up in a text editor to see if I could find where the heck the "socket" variable was trying to set itself to something with an unknown suffix

I also checked the configuration file "my.cnf" to see if I saw anything fishy in there, but everything looked okay to me.

Well, after hours of searching, I decided to try deleting my.cnf

IT WORKED!!! I have absolutely ZERO idea why, but it actually solved my problem.

So try and find my.cnf (for me, it was at /etc/mysql/my.cnf - but i have a book that says it can be located at /etc/my.cnf) I went ahead and saved a copy to a floppy disk in case I ever need to get my.cnf back, and then I deleted it!! IT WORKED. I'm still in shock.

best of luck to anyone else out there looking for a solution to this same problem

Options: ReplyQuote


Subject
Views
Written By
Posted
5736
December 27, 2004 04:24PM
Re: mysqldump -> Unknown suffix '/'
3118
January 30, 2005 03:04AM
3009
August 30, 2005 11:23AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.