Server won't start after system reboot
Posted by: John Sims
Date: September 14, 2022 11:07AM

I have a new installation of the latest version of mysql for Windows 11, running on a new machine. For the installation, I used defaults for everything, so all the directories are in default locations, with default permissions.
Everything worked fine until I rebooted my computer. Now, mysql attempts to start and then immediately shuts down. The relevant error message in the log file reads:
2022-09-14T16:50:21.079657Z 0 [ERROR] [MY-010326] [Server] Fatal error: Can't open and lock privilege tables: Table 'mysql.db' doesn't exist
2022-09-14T16:50:21.080223Z 0 [ERROR] [MY-010952] [Server] The privilege system failed to initialize correctly. For complete instructions on how to upgrade MySQL to a new version please see the 'Upgrading MySQL' section from the MySQL manual.
2022-09-14T16:50:21.081304Z 0 [ERROR] [MY-010119] [Server] Aborting
2022-09-14T16:50:22.332994Z 0 [System] [MY-010910] [Server] C:\Program Files\MySQL\MySQL Server 8.0\bin\mysqld.exe: Shutdown complete (mysqld 8.0.30) MySQL Community Server - GPL.

I've tried running mysqld --initialize to no avail. I've rechecked all the file permissions, and they remain default.
Can this installation be saved? If I reinstall, how can I tell the new installation where to find the database schema and contents I'd created?

John Sims

Options: ReplyQuote

Written By
Server won't start after system reboot
September 14, 2022 11:07AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.