MySQL Forums
Forum List  »  Connector/ODBC

Re: incorrect string value
Posted by: Артём Будейкин
Date: January 19, 2021 04:19PM

Thank you for your answer. I can say what data i try to insert. It's array of bytes like this - compressed array of bytes.

"lzma Аm@]  w®Ун‡AyІx‚ЮЙBІzlБ+ГXќб YїЮю¶#*>ъ*ґјё®Џ”.ЮА[|w¶R<і;уї1?ШрaЂжђЖшXYвJ_н;Z©;d"пGF ј{ЧхС‹Ш„ђG
СшЛ
wмЄ‚‡†
?«дё† оQO§O­b’~¶єь
џbm‚(
чКG©п=
б†чeе l€УХ®)гЇщклйЃ|цХµЌ6\d-Ь¬М|©3w•ў·ЊDВ0ящSА"

Some symbols not supported by this field, but in notepad i can see them all correctly.
If you decompress this data, you will see text file with this content

"Дата/время Длина Тип qg Qcum dP(dt) Номер первого инт-ла
ч тыс.м³/сут тыс.м³
19.07.2008 02:00:00 8360,88 Работа 494,13 172000
02.07.2009 10:53:00 317,183 КВД 0 172000 1"

I tried to insert not-copmpressed data too, with the same result. There is no place, there data can be corrupted, i checked it. Maybe ii need some sort of additional conversion to binary for set of bytes?

Options: ReplyQuote




Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.