the mysql connector net 6.4.4 package did not load correctly
Posted by: Eric Adolphson
Date: June 01, 2018 01:29PM

I am new to MySql. I am running Windows 10, Visual Studio 2012 and 2017. I have installed MySql using "mysql-installer-web-community-8.0.11.0.exe". I have tried to make sure I have the latest version of the MySQL tools.

MySQL installer has these items:
MySQL Server; ver: 5.7.22; Arch: X64
MySQL Workbench; ver 6.3.10; Arch: X64
MySQL for Visual Studio: 2.0.5 CTP; Arch: X86
Connector/NET; ver 8.0.11; Arch X86

I can run SQL Workbench, and see the data in tables I have created.

But now when I run Visual Studio 2012, I get this error message at startup:
"The 'MySQL Connector Net 6.4.4' package did not load correctly.
The problem may have been caused by a configuration change or by the installation of another extension. You can get more information by examining the file: 'C:\Users\UserName\AppData\Roaming\Microsoft\VisualStudio\11.0\Activity.log'.
Continue to show this message?"

I examined the 'Activity.log' file, and here is the section of the file dealing with the MySQL Connection Net:
<entry>
<record>32</record>
<time>2018/06/01 18:53:28.793</time>
<type>Information</type>
<source>VisualStudio</source>
<description>Begin package load [MySQL Connector Net 6.4.4]</description>
<guid>{79A115C9-B133-4891-9E7B-242509DAD272}</guid>
</entry>
<entry>
<record>33</record>
<time>2018/06/01 18:53:28.839</time>
<type>Error</type>
<source>VisualStudio</source>
<description>SetSite failed for package [MySQL Connector Net 6.4.4]</description>
<guid>{79A115C9-B133-4891-9E7B-242509DAD272}</guid>
<hr>80070002</hr>
<errorinfo>Could not load file or assembly 'Microsoft.VisualStudio.DataDesign.Interfaces, Version=14.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.</errorinfo>
</entry>

Visual Studio 2017 starts without any error messages, only Visual Studio 2012 has the problem.

I have two questions:
1) Why am I getting references to Connector/Net for version 6.4.4 when MySQL Installed says I have Connector/Net version 8.0.11?
2) How can I fix this error message?

Options: ReplyQuote


Subject
Written By
Posted
the mysql connector net 6.4.4 package did not load correctly
June 01, 2018 01:29PM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.