MySQL Forums
Forum List  »  Perl

Re: perl script hangs on query with where clause
Posted by: Kelly Jones
Date: January 15, 2009 10:35AM

I have this problem, using MYSQL 5.0.27 and perl 5.10. In my situation, it appears to happen on some tables and not others. Here was a simple select statement that caused a hang when passed through the DBI call:

>>>> Select sectype from securities where secsym='COP';

A similar simple select with where clause from another table worked fine. I was able to make a work around that eliminated the hang by joining the table of the non-working table with one that did work - not sure at all what the cause was or why this solved the problem, but it did, at least in this instance:

>>>> Select sectype from clients left join positions using (acctnum) left join securities using (secsym) where secsym='COP';

Clients had tested as a non-hanging table. I was surprised not to see more on the Perl site as to what the story is with this bug or errors in setup, whatever the cause.

Hope that may help you at least get functional. It's what we used to call a "kluge" - not the best solution, but lets the wheels of industry move forward...

Options: ReplyQuote

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.