MySQL Forums :: Perl :: DBD:Mysql make test fails on Solaris 10


Advanced Search

DBD:Mysql make test fails on Solaris 10
Posted by: jim Y. ()
Date: September 21, 2009 10:31AM

hello -

I have the following env on a Sun Fire X4200 server:

Solaris 10
gcc v3.4.6
DBI 1.609
DBD:Mysql 4.013
Test-Simple 0.94
Data Dumper 2.125
Data-ShowTable 3.3


Everything except DBD:Mysql seemed to build ok. The problem is with DBD::Mysql. Here's the result of "make test":

olyi:/app/archives/DBD-mysql-4.013 $ make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00base....................NOK 2
# Failed test 'use DBD::mysql;'
# at t/00base.t line 21.
# Tried to use 'DBD::mysql'.
# Error: Can't load '/app/archives/DBD-mysql-4.013/blib/arch/auto/DBD/mysql/mysql.so' for module DBD::mysql: ld.so.1: perl: fatal: libmysqlclient.so.12: open failed: No such file or directory at /usr/perl5/5.8.4/lib/i86pc-solaris-64int/DynaLoader.pm line 230.
# at (eval 7) line 2
# Compilation failed in require at (eval 7) line 2.
# BEGIN failed--compilation aborted at (eval 7) line 2.
FAILED--Further testing stopped: Unable to load DBD::mysql
*** Error code 29
make: Fatal error: Command failed for target `test_dynamic'

BTW, I had to hack the Makefile to change from 64-bit to 32-bit libraries, and change switches to use "gcc" instead of a "c" compiler for "make" to build. Is this typical? If the problem is obvious DO SHARE. This is the first time I've worked with any of these modules so i'm fairly ignorant to this.

thanks in advance,
Jim



Edited 1 time(s). Last edit at 09/22/2009 12:37PM by jim Y..

Options: ReplyQuote


Subject Written By Posted
DBD:Mysql make test fails on Solaris 10 jim Y. 09/21/2009 10:31AM
Re: DBD:Mysql make test fails on Solaris 10 John Goubeaux 10/12/2009 08:19PM
Re: DBD:Mysql make test fails on Solaris 10 james yeager 10/13/2009 09:39AM
Re: DBD:Mysql make test fails on Solaris 10 Lim KH 11/17/2009 12:18AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.