MySQL Forums
Forum List  »  Merge Storage Engine

Get error 1168 on merge tables after upgrade
Posted by: Riana Rossouw
Date: August 13, 2008 04:07AM

Good day

We run mysql on a RedHat Enterprise 5 IA64 server and use the mysql that comes with the RedHat Release.

We have recently upgraded from Enterprise 5.1 to Enterprise 5.2 which also upgraded our MySQL from version 5.0.22-standard-log to 5.0.45-log.

This resulted in all our Merge tables giving error 1168 (HY000): Unable to open underlying table which is differently defined or of non-MyISAM type or doesn't exist.

What can I do to fix this?
I have already run myisamchk -r on all the tables and have also checked the underlying tables' version (all are version 10).

Should I have performed some converions before the upgrade, or is there a utility that can be run now?

Any help will be appreciated.
Thanks
Riana

Options: ReplyQuote


Subject
Views
Written By
Posted
Get error 1168 on merge tables after upgrade
12089
August 13, 2008 04:07AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.