Re: Can't select/inserting/updating some Chinese Character.
Posted by: Qmingming zhao
Date: December 08, 2005 01:05AM

This can solve the question.
Please set client character set, if there still is any question.

Shuichi Tamagawa wrote:
> Hi Leung
> > What is the result of SHOW CREATE TABLE ?
> > {error}
> <your_table_name>;
> Anyway, according to the result of SHOW VARIABLE
> it seems that your table is created with latin1
> character set.
> If you want to store your data in Chinese
> encoding, you should set Chinese character set
> like big5, gb2312, gbk to those character set
> variables, and create the table with the
> characater set.
> Try the follwoing first, and see if it works:
> 1. Edit my.cnf(my.ini on Windows) and set default
> character set(e.g. gbk)
> default-character-set=gb2312
> default-character-set=gb2312
> 2. Start server. And login from mysql command line
> client whici is in bin directory.
> 3. Create table, Insert Chinese data, Select the
> data from the table.
> Regards,
> Shuichi

Options: ReplyQuote

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.