MySQL Forums
Forum List  »  Ruby

syntax error on line 18, col 2: ` socket: /tmp/mysql.sock'
Posted by: William Wright
Date: April 01, 2007 07:30PM

OK so Im a newbie with MySQL so please be nice :) I'm learning to use Ruby and MySQL and am going through the training for Ruby. I am the part where I run rake db:migrate, and I get this error

williams-computer:/usr/local/src/music_library william$ rake db:migrate
(in /usr/local/src/music_library)
rake aborted!
syntax error on line 18, col 2: ` socket: /tmp/mysql.sock'

(See full trace by running task with --trace)

Can anyone help with this. I cannot go any further until this is corrected. In the tutorial the teachers yml file says host: localhost where mine says socket: /tmp/mysql.sock'. So I replaced it with host: localhost and got the same error.


Options: ReplyQuote

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.