MySQL Forums
Forum List  »  InnoDB

Re: Error No. 1033 Incorrect information in file: 'filename'
Posted by: Antonio Beghi
Date: December 11, 2006 02:44AM

I had the same problem after i have changed mysql configuration through MYSQL Administrator.
MYSQL Administraton has a bug, it overwrites the my.ini file and put comments (#) everywhere.
So, do this:
1) switch to last backup of my.ini file (and copy it somewhere)
2) specify the path for innodb data file.
I have obtained the correct string using MYSQL Administration -> Startup variables -> innoDB variables -> check data file path
This action add a line at the end of my.ini (but again comment all other lines!)
So, copy this line (example: mine is innodb_data_file_path=ibdata1:102760448:autoextend), add the line to the old (and good!) my.ini and overwrite again the my.ini file with this file.
3) Restart
....And it works again!
Antonio Beghi.

infinitevs Wrote:
> Hi Everyone,
> I spoke to my web hosting company and they said
> that the INNODB database corrupted somehow.. I
> have no backups as they were supposed to daily and
> weekly backups, it took them a week to realise
> what happened so the backups got overwritten, and
> the corrupted tables did not backup as they were
> corrupted.
> When I click on the database tables in question
> they come up with:
> "Error No. 1033 Incorrect information in file:
> 'filename'"
> Is there anyway to recover this data or is it lost
> forever?
> kind regards,
> Sean.

Options: ReplyQuote

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.