MySQL Forums
Forum List  »  NDB clusters

SQL node not starting
Posted by: Shaun van Wyngaard
Date: November 28, 2017 04:20AM

I am trying to set up a cluster, with minimal configuration until I get it working, then I will fine tune it.

I have managed to get the mngt node & 2 data nodes running, however I can't get the sql node running, it starts, and then shuts down again with no further info at the prompt as to why it stopped.

I have used the no-install/zipped version.
I unzipped everything to the folder c:\mysql folder.
Under the MySQL folder I have the my.ini file with the following in...

[mysqld]
# Options for mysqld process:
ndbcluster #run NDB storage engine

[mysql_cluster]
# Options for NDB Cluster processes:
ndb-connectstring=192.168.7.112 #location of management server 1

At the command prompt I type in c:\mysql\bin\mysqld.exe
A few seconds later it stops and waits at the prompt again.

When I look in the file c:\mysql\data\MySQL-SRV.err I see a few errors like...
Table mysql.plugin doesn't exist...
Could not find database directory MySQL...

However, in the file I do see a reference to 192.168.7.112 which is my mngt node, so it looks like it is making contact with it.

I'm not sure how to proceed further, what to check for, if someone could suggest a way forward please.

Options: ReplyQuote


Subject
Views
Written By
Posted
SQL node not starting
381
November 28, 2017 04:20AM
262
November 28, 2017 05:57AM
165
November 28, 2017 07:40AM
145
November 29, 2017 02:06AM
147
November 29, 2017 06:19AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.