MySQL Forums
Forum List  »  Replication

Re: Replication crashes when max_bin_log_size is reached
Posted by: Pär Iwarson
Date: March 15, 2005 10:04AM

We have still not solved this problem. I've thought I could get around it by doing "FLUSH LOGS" before the relay log reached the max_bin_log_size. But the same thing happened when I ran "FLUSH LOGS". was corrupted in the same way and the relay log did not rotate. So it seems that I have no other option than to install the latest 4.1 version and hope that it will work then. Unless someone know anything that could help me.

This time the error log looked like this:

050313 3:40:40 Slave I/O thread killed while reading event
050313 3:40:40 Slave I/O thread exiting, read up to log 'freebsds-bin.006', position 399146999
050313 3:40:40 Error reading relay log event: slave SQL thread was killed
050313 3:41:10 Could not use ensim-relay-bin for logging (error 13). Turning logging off for the whole duration of the MySQL server process. To turn it on again: fix the cause, shutdown the MySQL server and restart it.

The rest is just like before.

Options: ReplyQuote

Written By
Re: Replication crashes when max_bin_log_size is reached
March 15, 2005 10:04AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.