MySQL Forums
Forum List  »  Newbie

Re: root user cannot change system variables?
Posted by: Karl Jenkinson
Date: January 15, 2022 01:19AM

Thank you Peter.

I found the page. Unfortunately, all their advice fails.
1. When I open the Options File menu choice, the window is greyed out. I cannot create my own config file.
2. As you pointed out, there are no sample my.cnf files installed, so I cannot copy one.

Lastly, the MySQL server has completely failed. It no longer starts. I tried uninstalling, restarting the computer, and re-installing. I even tried a fresh download of the package. My computer completely fails to run the MySQL server now. I hacked into the log file and found these messages repeated many times each time I tried to start the server:
2022-01-15T06:47:39.513004Z 0 [ERROR] [MY-000058] [Server] Unknown suffix '%' used for variable 'port' (value '%PORT%').
2022-01-15T06:47:39.513017Z 0 [ERROR] [MY-000077] [Server] /usr/local/mysql/bin/mysqld: Error while setting value '%PORT%' to 'port'.
2022-01-15T06:47:39.513856Z 0 [ERROR] [MY-010119] [Server] Aborting
2022-01-15T06:47:39.513945Z 0 [Note] [MY-010120] [Server] Binlog end

I have not searched the forum for this error. Has it already been answered?

Regards,
Karl

Options: ReplyQuote




Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.