MySQL Forums
Forum List  »  Connector/ODBC

Re: Error using SSL in Connector/ODBC. SSL works fine with Workbench.
Posted by: Michael K
Date: March 24, 2020 04:08PM

I just tried making a new connection in Workbench and it worked. I left SSL options as defaults. But when I try entering in any SSL options, I get the "certificate verify failed" error. Even if I leave everything blank and set Use SSL "No", it fails with "access denied for user" error. What? It only works with Use SSL set to "If available". Also, even with no SSL options set, it shows SSL: Enabled with TLS_AES_256_GCM_SHA384 in the test info.

I guess I will leave it as it is since it says it is connected with SSL, also when I query with - SHOW SESSION STATUS LIKE 'Ssl_cipher' it shows TLS_AES_256_GCM_SHA384.

That doesn't solve the original problem with Connector/ODBC and SSL though. I wonder if it is also using SSL, but just doesn't say. The only thing that test says is "Connection Successful".

Options: ReplyQuote

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.