LOAD DATA INFILE again ...
Posted by: Michael Peters
Date: June 07, 2019 02:43AM

A crucial part of the app that I converted from SQLServer to MySQL is that data need to be imported from txt files on a daily basis. The import code in the app contains this:

LOAD DATA LOCAL INFILE ‘#importfilename#’ INTO TABLE bulkimport

(Without LOCAL specified, I get "The MySQL server is running with the --secure-file-priv option so it cannot execute this statement")

With LOCAL specified, I get “The used command is not allowed with this MySQL version”.

Adding “allowLoadLocalInfile=true” to the connection string doesn’t change anything.

Adding “local-infile = 1” to my.ini doesn’t change anything.

The strange thing is that the import runs fine when using Coldfusion, but it needs to run in Lucee, and Lucee produces this error. Some difference in the MySQL driver? Anyway:

I need your help, and of course it is urgent :)

-Michael

Options: ReplyQuote




Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.