MySQL Forums
Forum List  »  Install & Repo

Re: Error Nr. 1045 Access denied for user 'root'@'localhost' (Using password: NO)
Posted by: mike gieson
Date: January 05, 2006 05:01PM

To overcome this issue:

1. Use the MySQL installer again and don't do anything fancy, just click next, next, next, yes, yes, yes. This should install, set up and start MySQL.

2. Open the port using the Windows Firewall. Start > Control Panels > Windows Firewall > Exceptions tab.

3. Click the "Add Port" button:
Name: mysql
Port: 3306

4. Click the "Add Program" button.
Browse to MySQL ( C:/Programs Files/mysql 5.x.x/bin/mysql.exe )

5. If you want, reboot your computer (this is what I did, just in case).

6. Download the the MySQL Administrator program:

7. After unzipping, launch "MySQLAdministrator.exe" directly out of the unzipped directory by double clicking on the MySQL Administrator.exe file.

Server host: localhost
Username: root
Password: whatever

Click "OK"

8. Click on the "Startup Variables" item on the left, then the "Security" tab. Check the checkbox for "Disable grant tables."

9. Click the "Service Control" item on the left and then the "Start/Stop Service" tab.

10. Click "Stop Service" -- once the services has stopped, click the button again to start the service.

If you've got PHP installed on your system, I recommend using phpMyAdmin to maintain MySQL:

- mike


Edited 1 time(s). Last edit at 01/05/2006 05:05PM by mike gieson.

Options: ReplyQuote

Written By
August 23, 2010 05:37AM
October 08, 2010 02:25PM
Re: Error Nr. 1045 Access denied for user 'root'@'localhost' (Using password: NO)
January 05, 2006 05:01PM
October 15, 2011 11:03PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.