MySQL Forums
Forum List  »  Install & Repo

Found the cause and have a fix !!!
Posted by: Steve Hill
Date: July 22, 2007 04:44PM

I fought with this error all afternoon:

Could not start the service MySQL. Error:0

I tried going through the registry, killing the service, everything from this thread with no luck - the error kept coming back. Here's what I finally figured out. When you go through the installation, when it asks for the location where the innodb should be stored it has a drive letter and a path. I was entering C:\InnoDB in the field (I was copy pasting it from a forum). Looking at the my.ini file, it has this:

#*** INNODB Specific options ***

This obviously won't work.


don't even worry about stopping your install.
kill the existing service with "sc delete MySQL"
click back until you get to the field I mentioned. Just put a path - in my case InnoDB and then complete the install. After 2+ hours of frustration this fixed it for me!

Options: ReplyQuote

Written By
March 26, 2009 06:32PM
April 28, 2009 09:16AM
June 05, 2009 08:59AM
January 19, 2005 09:57AM
Found the cause and have a fix !!!
July 22, 2007 04:44PM
August 16, 2007 10:20AM
August 19, 2007 08:57PM
December 05, 2008 10:07PM
April 26, 2009 05:29PM
August 15, 2009 07:47AM
August 30, 2008 11:22AM
November 18, 2004 05:24PM
February 27, 2005 01:55PM
July 01, 2009 05:46AM
July 01, 2009 03:41PM
July 01, 2009 05:08PM
July 01, 2009 11:52PM
July 09, 2009 02:07AM
July 21, 2009 10:49PM
September 04, 2009 09:09AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.