MySQL Forums
Forum List  »  Install & Repo

Re: Another Possible Fix
Posted by: Christopher Swearingen
Date: November 23, 2009 11:33AM

Alex Pennington Wrote:
> OK, as so many before I have yet another possible
> fix.
> What happens is something gets stuck in the setup
> that stays after uninstallation. What I have done
> to resolve this is.
> * I use the .msi installer that I installed it
> with to uninstall it.
> * Then just to make sure I run on the command
> line; sc delete MYSQL (or w/e your service is
> named)
> * I then go and delete the folder it was installed
> to.
> So far this is common practice, but here is the
> thing I stumbled upon that no one else touched
> on.
> * Finally I delete the C:/Documents and
> Settings/All Users/Application Data/MySQL folder
> * Now when I reinstall all works fine.
> I found a early warning that it will fail if you
> set up a root password then when asking for the
> root pass again it asks for your current root
> password. This will likely mean that your install
> will fail. The install failing is not due to the
> service not getting created or removed properly
> but rather a fault in the mysqld daemon. Command
> line running of the daemon yields a crash every
> time for me at least. To solve that I simply
> followed the steps I listed above and it worked.
> Now I know this is a less than optimal (hardly
> possible) solution for those who have existing
> data since the App Data MySQL folder is the heart
> of your data (according to the conf file anyways)
> but since I was doing this on a fresh install I do
> not know or have the time to research other
> solutions.
> I hope this helps,
> --Axpen

These are the exact options that finally worked for me. Here's my detailed account of running into, and solving, Error 0.

1. Running Windows Server 2003 and trying to reinstall MySQL 5.1.34. Got the dreaded error 0.
2. Used the "msiexec /x mysql-essential-5.1.34-win32.msi" command to uninstall.
3. Deleted the hidden files and folders from Application Data folder in All Users.
4. Deleted the installation folder tree from C:\Program Files
5. Re-ran the .msi installer and it worked! :D

Options: ReplyQuote

Written By
March 26, 2009 06:32PM
April 28, 2009 09:16AM
June 05, 2009 08:59AM
January 19, 2005 09:57AM
August 16, 2007 10:20AM
August 19, 2007 08:57PM
December 05, 2008 10:07PM
April 26, 2009 05:29PM
August 15, 2009 07:47AM
August 30, 2008 11:22AM
November 18, 2004 05:24PM
February 27, 2005 01:55PM
July 01, 2009 05:46AM
July 01, 2009 03:41PM
July 01, 2009 05:08PM
July 01, 2009 11:52PM
July 09, 2009 02:07AM
July 21, 2009 10:49PM
September 04, 2009 09:09AM
Re: Another Possible Fix
November 23, 2009 11:33AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.