MySQL Forums
Forum List  »  Install & Repo

Possible Fix
Posted by: Ryan Banks
Date: July 01, 2009 05:46AM

Ok so if like me you have tried every fix under the sun then read up, this may just work for you.

First i would like to pay respects to everyone who has tried to fix this and spent the time posting about it.

Okay, so my fix follows as so:

First remove ALL server instances, (Start, All programs, mySql, MySQL server instance config wizard) make sure to remove everything.

Next make sure no sql services are running (start, run, services.msc /r) (There shouldn't be if you have removed every instance)

Next uninstall MySQL (uninstall everything related in add and remove programs)

Next delete both the install dir (where you installed it, i.e. C:\Program Files\MySql)

Now the important bit, Remove all application data from every user, To do this go to your local drive (c:\ (or if you've changed it) next goto all users, application data (this may be hidden, (tools, show hidden files and folders) then delete MySql data) do this for ALL users!

Now restart, (this may not be required but it will stop ALL services and restart them).


Now when you are back in, reinstall the MySQL MSI package (for this i used 5.1)
Install as usual, next comes the hated config manager.

My settings for my 2003 windows server are as followed (if i dont list them, they are default)

Detailed Configuration

Server Machine

Multifunctional Database

Defualt dir

Decision support
Enable TCp (add expectation)
Enable Strict mode

Standard Char set

Default service name (some found changing it helps, i didn't keeping it default should work)
Also include bin directory

now this is where its make or break ( if you see current password, your database is still open and you must have missed a step, or you should look towards the REGEDIT steps listed in this thread)
-- If however you see just password and repeat then we are on track, now enter a password and repeat it.

before clicking next open up services again (services.msc /r) now click next and wait for that error (if you don't get it, then congrats) if you do however, now goto the services window and right click refresh, look for MySQL and check the status, if it is running, we are on track :) if not, again this hasn't worked and stop here.

with the service running, you will want to close the configuration windows and reopen it (to do this, Start, All programs, mySql, MySQL server instance config wizard) now goto reconfigure instance, follow it through all the way (next, next, next) till you get to the password page (last window) here it will say current password, leave this blank (this is because the configuration never made it to setting security) now enter a password of your choice, and hit next and execute.

Hopefully we should be looking at a successful windows displaying the service started!

Hope this helps guys :)

Ryan Banks

Options: ReplyQuote

Written By
March 26, 2009 06:32PM
April 28, 2009 09:16AM
June 05, 2009 08:59AM
January 19, 2005 09:57AM
August 16, 2007 10:20AM
August 19, 2007 08:57PM
December 05, 2008 10:07PM
April 26, 2009 05:29PM
August 15, 2009 07:47AM
August 30, 2008 11:22AM
November 18, 2004 05:24PM
February 27, 2005 01:55PM
Possible Fix
July 01, 2009 05:46AM
July 01, 2009 03:41PM
July 01, 2009 05:08PM
July 01, 2009 11:52PM
July 09, 2009 02:07AM
July 21, 2009 10:49PM
September 04, 2009 09:09AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.