MySQL Forums
Forum List  »  Install & Repo

*FIX for* ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
Posted by: Margaret MacDonald
Date: December 16, 2007 09:06AM

This applies only to 5.0.45 under Windows

Edited my.ini (my.cfg under Unix) and include the line 'skip-grants-tables' under the mysqld section. I can't remember who first suggested this in this thread, but kudos to whoever it was.

That let me start the command-line interface (mysql.exe). Looking at the root account in user (SELECT * FROM user \G) showed a bad password (it had a leading star (*) in mine). Doing UPDATE user SET PASSWORD='' cleared the pw. Since I only had the root account defined, I didn't need to specify the account, and since it's my dev machine I don't need a pw.

I then removed the 'skip' line from the ini file and everything works.

I've reported the bug.

Edited 1 time(s). Last edit at 12/16/2007 09:22AM by Margaret MacDonald.

Options: ReplyQuote

Written By
June 27, 2009 08:29PM
December 16, 2007 02:18AM
December 27, 2007 02:08PM
January 16, 2011 06:51AM
*FIX for* ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
December 16, 2007 09:06AM
August 27, 2009 12:22AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.