MySQL Forums
Forum List  »  Install & Repo

Don't forget to also...
Posted by: Iain Hunneybell
Date: January 03, 2006 07:48AM

I've been through this "mysql_connect(): Client does not support authentication protocol requested by server" problem a few times on different builds and it's always that you can remember the problem but not the details of how you fixed it last time!

mglatts' (,219241) documentation of setting the old_password setting is excellent, but one final thing...

If, like me, you *did* define a root password during installation you're still stuck. The reason is the root password was set in the 'new' stronger password format during installation and so the old_password setting doesn't help you. It just helps you not 'un-fix' things later.

Therefore, if like me, you *did* set a root password during setup, you also need to reset the root password to the 'old encryption' basis.

How to do this is nicely documented here by flamtriplets_2000 (,241156), but to save you looking for this post (,6400,15113#msg-15113) I quote from flamtriplets_2000:

After starting the MySQL Command Line Client:

set password in old format:
mysql> SET PASSWORD FOR root@localhost = OLD_PASSWORD('mypass');

This now resets the password you established during installation and which was in 'new' format to be in 'old' format which should work with php/MySQLadmin. Now you should be motoring :-)


Options: ReplyQuote

Written By
December 31, 2005 12:02AM
December 31, 2005 02:28AM
March 29, 2006 03:12AM
March 24, 2007 02:58PM
Don't forget to also...
January 03, 2006 07:48AM
March 16, 2006 10:03AM
November 02, 2005 07:38AM
January 16, 2006 03:46PM
July 24, 2006 07:40AM
March 28, 2006 11:18PM
August 23, 2006 01:21PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.