MySQL Forums
Forum List  »  InnoDB

Re: ERROR 1005: Can't create table (errno: 150) [ANOTHER SOLUTION]
Posted by: Esen Sagynov
Date: April 17, 2011 05:39AM

Jim Smith Wrote:
-------------------------------------------------------
> In my case, the problem was that the NAMES of the
> foreign keys were not unique.
> I wasn't aware that this was a requirement, but
> changing them worked.
> So I changed the line:
> KEY `fk_productid`
> to
> KEY `fk_productid222`
>
> And it worked! (This was because another table
> was using the foreign key name "fk_productid"

This is really stupid, but it solved my problem. I suppose MySQL keeps track of constraint names globally for the current database, so names should be unique.
CUBRID DBMS (http://www.cubrid.org), for example, creates constraints per table, which does not make me search for an hour for such kind of solution.

Options: ReplyQuote


Subject
Views
Written By
Posted
655683
March 24, 2005 01:20PM
10090
October 09, 2012 09:48PM
Re: ERROR 1005: Can't create table (errno: 150) [ANOTHER SOLUTION]
13130
April 17, 2011 05:39AM
4647
December 19, 2011 10:13PM
10814
May 09, 2006 06:01PM
13533
November 15, 2006 02:05PM
8441
T D
February 01, 2008 06:47AM
10765
August 27, 2008 08:08AM
11862
December 03, 2008 10:15AM
7109
May 01, 2009 07:39AM
4413
August 29, 2011 04:46PM
6018
s l
December 15, 2009 01:48PM
7279
December 22, 2009 02:54AM
5874
February 18, 2011 08:55AM
8433
May 24, 2011 10:11AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.